Vulnerabilities are possible if Drupal is configured to allow use of the CKEditor library for WYSIWYG editing. An attacker that can create or edit content (even without access to CKEditor themselves) may be able to exploit one or more Cross-Site Scripting (XSS) vulnerabilities to target users with access to the WYSIWYG CKEditor, including site admins with privileged access.
For more information, see CKEditor's security advisories:
This advisory is not covered by Drupal Steward.Solution:
Install the latest version:
- If you are using Drupal 9.2, update to Drupal 9.2.9.
- If you are using Drupal 9.1, update to Drupal 9.1.14.
- If you are using Drupal 8.9, update to Drupal 8.9.20.
Versions of Drupal prior to 9.1.x are end-of-life and do not receive security coverage.
Note that Drupal 8 has reached its end of life so this is the final security release provided for Drupal 8.
Drupal 7 core does not include the CKEditor module and therefore is not affected.Reported By:
- Jacek Bogdański coordinated on the release with Drupal project.
- See the CKEditor announcements above for the original reporters of the vulnerabilities.